Logo PostgreSQL (imagen destacada)

Tiro monedas al aire, pero hasta ahora nunca las pude agarrar.

Logo PostgreSQL
Logo PostgreSQL

Entramos a la terminal y tecleamos lo siguiente:
sudo apt-get update
sudo apt-get install postgresql-9.5 postgresql-9.5-postgis-2.2 postgresql-9.5-postgis-scripts

Ahora cambiamos el password del usuario postgres. Entramos a la consola:
sudo passwd postgres

Sale esto por pantalla:
Introduzca la nueva contraseña de UNIX:
Vuelva a escribir la nueva contraseña de UNIX:
passwd: contraseña actualizada correctamente

Volvemos a escribir en la consola:
su postgres
psql

Una vez dentro de psql, escribimos en la consola:
\password postgres

Sale esto por consola:
Enter new password:
Enter it again:
postgres=#

Ahora salimos.
\q

Creamos una base de datos y en este caso sería template_postgis. Entramos a la consola y tecleamos:
createdb template_postgis
psql -U postgres -d template_postgis -f /usr/share/postgresql/9.5/contrib/postgis-2.2/postgis.sql
psql -U postgres -d template_postgis -f /usr/share/postgresql/9.5/contrib/postgis-2.2/spatial_ref_sys.sql
psql -U postgres -d template_postgis -f /usr/share/postgresql/9.5/contrib/postgis-2.2/postgis_comments.sql

Volvemos a escribir en al consola:
psql template_postgis

Ahora estamos en la base de datos template_postgis. Para saber si esta base de datos contiene postgis, escribimos:
SELECT postgis_full_version();

Sale por pantalla:
template_postgis=# SELECT postgis_full_version();
NOTICE: Function postgis_gdal_version() not found. Is raster support enabled and rtpostgis.sql installed?
NOTICE: Function postgis_raster_scripts_installed() not found. Is raster support enabled and rtpostgis.sql installed?
NOTICE: Function postgis_raster_lib_version() not found. Is raster support enabled and rtpostgis.sql installed?
postgis_full_version
----------------------------------------------------------------------------------------------------------------------------
POSTGIS="2.2.1 r14555" GEOS="3.5.0-CAPI-1.9.0 r4084" PROJ="Rel. 4.9.2, 08 September 2015" LIBXML="2.9.3" LIBJSON="0.11.99"
(1 row)

Comments

comments


Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *