Tiro monedas al aire, pero hasta ahora nunca las pude agarrar.

VLC 2.0.4 en Ubuntu 12.04 de 32 bits

Quería tener VLC 2.0.4 en mi Ubuntu 12.04 de 32 bits así que, manos a la obra.
OBS:

  • Si tenemos una versión anterior del VLC, debemos de desinstalar.

Entramos a la consola y escribimos:
sudo aptitude update
wget -c http://download.videolan.org/pub/videolan/vlc/2.0.4/vlc-2.0.4.tar.xz
sudo aptitude install libtool build-essential pkg-config autoconf xz-utils liblua5.1-0-dev lua5.1 libmad0-dev libavcodec-dev libavformat-dev libswscale-dev libpostproc-dev liba52-0.7.4-dev libxcb-composite0-dev libxcb-xv0-dev libasound2-dev
sudo aptitude install libavcodec-dev
sudo aptitude install libraw1394-dev zvbi libbluray-dev libsidplay2-dev libgcrypt11-dev libdca-dev libflac-dev libmpeg2-4-dev libvorbis-dev libass-dev libkate-dev libnotify-dev portaudio19-dev

Esto me sale en pantalla:
No se satisfacen las dependencias de los siguientes paquetes:
libraw1394-tools : Rompe: libraw1394-dev (<= 2.0.7-1ubuntu1) pero se va a instalar 2.0.7-1ubuntu1.
libjack0 : Entra en conflicto: libjack-0.116 que es un paquete virtual.
libjack-jackd2-0 : Entra en conflicto: libjack-0.116 que es un paquete virtual.
Entra en conflicto: libjack0 pero se va a instalar 1:0.121.0+svn4538-3ubuntu1.
Las acciones siguientes resolverán estas dependencias

Eliminar los paquetes siguientes:
1)     libjack-jackd2-0

Mantener los paquetes siguientes en la versión actual:
2)     libraw1394-tools [Sin instalar]

Dejar las siguientes dependencias sin resolver:
3)     libraw1394-dev recomienda libraw1394-tools


¿Acepta esta solución? [Y/n/q/?]

Y ahí aceptamos.
Volvemos a escribir en la consola:
sudo aptitude install libdbus-1-dev libx11-xcb-dev libavc1394-dev libqt4-dev libprojectm-dev libavahi-client-dev libudev-dev libmtp-dev libupnp-dev
sudo aptitude install libtwolame-dev
tar -Jxvf vlc-2.0.4.tar.xz
cd vlc-2.0.4
./configure

Sale esto por pantalla:
libvlc configuration
--------------------
version               : 2.0.4
system                : linux
architecture          : i686 mmx sse sse2
optimizations         : yes
vlc aliases           : cvlc rvlc svlc qvlc


To build vlc and its plugins, type `make', or `./compile' if you like nice colors.

Volvemos a escribir en la consola:
make

OBS:
El make puede tardar mucho dependiendo de tu hardware.

Volvemos a escribir en la consola:
sudo make install

Luego, volvemos a escribir en la consola:
sudo ln -s /usr/local/lib/libvlc* /usr/lib/
sudo ln -s /usr/local/lib/libx264.a /usr/lib/
sudo ln -s /usr/local/lib/vlc /usr/lib/vlc

Volvemos a escribir en la consola:
vlc

Y ya podremos usar la última versión de VLC (2.0.4) en Ubuntu 12.04 de 32 bits.

Comments

comments


Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *