Tiro monedas al aire, pero hasta ahora nunca las pude agarrar.

gvSIG 2.0 en Debian Wheezy
gvSIG 2.0 en Debian Wheezy

Para tener gvSIG 2.0 en Debian Wheezy debemos descargar del sitio oficial.

OBS:

  • Ser root.
  • Usamos java 7 de Oracle.

Una vez descargado, entramos a la consola donde se encuentra el binario y cambiamos de permiso para poder ejecutar.
chmod +x gvSIG-desktop-2.0.0-2066-final-lin-x86-standard-withjre.bin
./gvSIG-desktop-2.0.0-2066-final-lin-x86-standard-withjre.bin

Ahora deben de instalar gvSIG e su sistema. La instalación es muy sencilla, y luego ya podrán usar gvSIG en su Debian Wheezy. 🙂

Comments

comments


Comments

  1. Hola José, por error instalé gvSIG en root. Apreciaría tu ayuda para desisnstalarlo. Podrías ayudarme, por favor.

    Saludos

    1. Hola. Entra en la carpeta donde instalaste gvSIG. Seguramente lo hiciste en /root/ pero podría estar en otro lado. Para buscarlo podrías utilizar «locate gvsig» en la consola, pero antes ejecuta «updatedb».
      Una vez encontrado la carpeta gvSIG esta el desinstalador, y ejecuta ahí. No recuerdo mas tan bien se se desinstalaba de esta manera. «./unistall» o algo por el estilo. Tendrías que ver dentro de la carpeta. Cualquier cosa avisame.
      Saludos, jose

      1. Hola José, una sincera disculpa por responder hasta ahora. Enseguida procedo a realizar tus indicaciones. Muchas gracias.

          1. José, hola nuevamente. No logro que gvSIG2.0.0-final abra archivos ráster. Se debe a que necesito establecer un ambiente JAVA de 32 bits. Por favor podrías ayudarme. Utilizo un equipo con DEBIAN 7 Wheezy a 64. Tengo la versión 7 de JAVA. La debo instalar en la carpeta de gvSIG? El sistema utiliza la versión 6.

            Gracias de antemano.

          2. José, muchas gracias. Lo hago y ya te aviso. Encontré que si tengo instalada JRE 7, pero como no se sí deba desinstalar la 6, por ello gvSIG no reconozca la 7.

            Aprecio tu ayuda. Buen fin de semana,

            Porfirio

          3. Hola José, buen día. Hice tal y como indicaste. El software se instaló y abrí varios raster y archivos .shp. Lo cerré y al abrirlo de nuevo aparece el recuadro que indica que hay algunos archivos que no son compatibles con la arquitectura y además que se requiere establecer un ambiente a 32 bits. Tengo instalada también la 1. 12.

            Al revisar en el sistema encuentro que tengo varias versiones de Java: OJDK 7, jre 7 y por supuesto la 6.

            Por favor, podrías indicarme que hacer?

            Gracias,

            Armando

          4. Hola Armando.
            Instalaste la versión 2.0 y te abrió los archivos. Luego volviste a entrar a la versión 2.0 y ahí te da errores?. Es así?

            Acá escribí un post sobre el tema. http://proyectosbeta.net/2013/08/instalar-gvsig-2-0-en-debian-wheezy-de-64-bits/
            Capaz que haya problemas con el gvSIG 1.12 y las versiones de java. Vamos a descartar opciones.
            Primero desinstala la versión 1.12 de gvSIG con su correspondiente versión de java.
            Y contame ahí si te funciona o no.
            saludos, jose

          5. Hola José. Tal y como te comento, instalé la versión 2.0.0-2066 final de gvsig. Inmediatamente después de la instalación la probé abriendo vistas y cargando archivos raster y .shp. Funcionó muy bien, aunque un poco lenta.

            Para continuar con la prueba cerré el programa y lo reinicié. Al terminar de abrir fue cuando apareió la ventana que indica la incompatibilidad de archivos instalados y el requerimiento de un ambiente JRE a 32 bits.

            Hasta donde pude revisé el sistema. Encontré que tengo dos versiones de Java: la jre-7u25 -linux – i586 y la jre-7u21-linux-x64. Así como la 6.

            Saludos.

            Armando

  2. Hola Armando Colliere:
    Que error te sale específicamente?. Así te ayudo. Si necesitas un entorno de 32 bits, te recomendaría tener un sistema de 32 bits. Te ahorras problemas y dolores de cabeza.
    Si tienes java 7 me supongo que te referís a Oracle Java 7?. O me equivoco. Que sistema utiliza la versión 6?. Te referís al gvSIG 2?
    Avisame cualquier cosa, así encontramos la solución.
    saludos, jose

    1. Hola José, muchas gracias. Tienes razón. Confieso mi ignorancia y no se como hacerlo pues la lap tiene un sistema a 64 bits. Tengo instalado DEBIAN 7 Wheezy a 64 bits. Al pulsar el comando java -version me indica que utiliza JDK 6. En la respuesta a mi solicitud de ayuda a la lista de gvSIG me dicen que la versión 2.0.0-final, por defecto detecta la versión de Java instalada en el sistema. Desinstalé gvSIG y lo reinstalé siguiendo las instrucciones. Al finalizar la instalación de gvSIG, aparece una ventana que me indica que hay paquetes de archivos que no son compatibles con el sistema y recomienda configurar un entorno a 32 bits. Eso se hace, según entendí, mediante el administrador de complmentos del propio gvSIG. La cuestión es que no lo logro y no puedo visualizar archivos raster.

      También debo instalar la versión 1,12 de gvSIG que es la final y estable y que contiene aplicaciones que todavía no están incorporadas a la versión 2.0.0-final.

      Utilizando el instalador de paquetes Synaptic, he tratado de cambiar la versión de la JDK utilizando «Forzar versión», pero no lo hace.

      Agradezco de antemano tu apoyo.

      Armando

      1. bueno. Probé en un Debian Wheezy de 64 bits y me ha funcionado levantar archivos raster.
        Bajate del sitio oficial el binario que pesa 231 megas.
        Desinstala de nuevo el gvGIS 2.0
        Al instalar elije donde dice Install a new Java Runtime Environment. Te va a instalar el java que trae por defecto el gvSIG. No hace falta instalar ningún java.
        Luego seguimos adelante hasta terminar de instalar todo.
        Ahora ya podras levantar archivos raster.

        En cuanto a la versión 1.12 debería de ser lo mismo. No te puedo asegurar, pero intenta. Cualquier cosa que no puedas, avísame que te ayudo
        saludos, jose

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *