Para tener PostGIS 2.1.2 en Ubuntu 14.04 LTS hacemos lo siguiente.

OBS:

  • Se usa Ubuntu 14.04 de 64 bits.

Entramos a la consola y escribimos:
sudo apt-get update
sudo aptitude install postgresql postgresql-client postgresql-contrib pgadmin3 postgis postgresql-9.3-postgis-2.1

Volvemos a escribir en la consola:
sudo su root
su postgres
psql

Una vez dentro de psql, escribimos en la consola:
\password postgres

Sale esto por consola:
Enter new password:
Enter it again:
postgres=#

Ahora salimos.
\q

Creamos una base de datos y en este caso sería template_postgis. Entramos a la consola y escribimos:
createdb template_postgis
psql -U postgres -d template_postgis -f /usr/share/postgresql/9.3/contrib/postgis-2.1/postgis.sql
psql -U postgres -d template_postgis -f /usr/share/postgresql/9.3/contrib/postgis-2.1/spatial_ref_sys.sql
psql -U postgres -d template_postgis -f /usr/share/postgresql/9.3/contrib/postgis-2.1/postgis_comments.sql

Volvemos a escribir en al consola:
psql template_postgis

Ahora estamos en la base de datos template_postgis. Para saber si esta base de datos contiene postgis, escribimos:
SELECT postgis_full_version();

Y nos saldrá por pantalla:
-----------------------------------------------------------------------------
POSTGIS="2.1.2 r12389" GEOS="3.4.2-CAPI-1.8.2 r3921" PROJ="Rel. 4.8.0, 6 March 2012" LIBXML="2.9.1" LIBJSON="UNKNOWN"
(1 row)

Con esto comprobamos que funciona correctamente PostGIS 2.1.2 en nuestra base de datos.

 

Comments

comments


Comments

  1. Hola. Cuando executo
    «psql -U postgres -d template_postgis -f /usr/share/postgresql/9.3/contrib/postgis-2.1/postgis.sql»

    obtengo el error:

    /usr/share/postgresql/9.3/contrib/postgist-2.1/postgis.sql: No such file or directory.

    Cuando dí sudo aptitud cambie por sudo apt ya que no reconció el comando aptitud y al final de la instalación obtuve:

    The following packages have unmet dependencies:
    postgis : Depends: libgdal1 (>= 1.9.0) but it is not going to be installed
    postgresql-9.3-postgis-2.1 : Depends: libgdal1 (>= 1.9.0) but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *