Disponer de herramientas en nuestra distro para poder determinar todo tipo de temas es siempre bienvenido. En este caso toca el tema de seguridad.

Obs:

  •  Utilizo Ubuntu Beaver Bionic 18.04 LTS de 64 bits.

En nuestra distro existen paquetes y cada paquete tiene que ser mantenido. Varios pueden dejar de tener soporte y para determinarlo debemos de tener instalado en nuestro sistema. Entramos a la terminal y tecleamos lo siguiente:
sudo apt update

sudo apt install debian-security-support

sudo apt clean && sudo apt autoclean

Ahora para comprobar si existen paquetes sin disponer soporte en nuestro sistema debemos ejecutar:
check-support-status

Sale por pantalla en mi caso:

Comprobar si un paquete dispone de soporte de seguridad en Ubuntu
Comprobar si un paquete dispone de soporte de seguridad en Ubuntu

En mi caso, solo tengo un paquete que es libqt5webkit5.
Para comprobar que paquetes dependen de el.
apt-cache showpkg libqt5webkit5

Sale lo siguiente:
Package: libqt5webkit5
Versions:
5.212.0~alpha2-7ubuntu1 (/var/lib/apt/lists/py.archive.ubuntu.com_ubuntu_dists_bionic_universe_binary-amd64_Packages) (/var/lib/dpkg/status)

Description Language:


File: /var/lib/apt/lists/py.archive.ubuntu.com_ubuntu_dists_bionic_universe_binary-amd64_Packages


MD5: b6887c4796db0313f1e533c538960454


Description Language:


File: /var/lib/apt/lists/py.archive.ubuntu.com_ubuntu_dists_bionic_universe_binary-i386_Packages


MD5: b6887c4796db0313f1e533c538960454


Description Language: en


File: /var/lib/apt/lists/py.archive.ubuntu.com_ubuntu_dists_bionic_universe_i18n_Translation-en


MD5: b6887c4796db0313f1e533c538960454

Reverse Depends:
qt56-teamviewer,libqt5webkit5 5.1.1

teamviewer-host,libqt5webkit5 5.5


teamviewer-host,libqt5webkit5 5.5


teamviewer-host,libqt5webkit5 5.5


teamviewer-host,libqt5webkit5 5.5


teamviewer-host,libqt5webkit5 5.5


teamviewer-host,libqt5webkit5 5.5


teamviewer-host,libqt5webkit5 5.5


teamviewer-host,libqt5webkit5 5.1.1


teamviewer-host,libqt5webkit5 5.1.1


teamviewer-host,libqt5webkit5 5.1.1


teamviewer-host,libqt5webkit5 5.1.1


teamviewer,libqt5webkit5 5.5


teamviewer,libqt5webkit5 5.5


teamviewer,libqt5webkit5 5.5


teamviewer,libqt5webkit5 5.5


teamviewer,libqt5webkit5 5.5


teamviewer,libqt5webkit5 5.5


teamviewer,libqt5webkit5 5.5


teamviewer,libqt5webkit5 5.1.1


teamviewer,libqt5webkit5 5.1.1


libqt5webkit5-dev,libqt5webkit5 5.212.0~alpha2-7ubuntu1


libqgis-gui3.6.3,libqt5webkit5 5.6.0~rc


libqgis-gui3.6.2,libqt5webkit5 5.6.0~rc


libqgis-gui3.6.1,libqt5webkit5 5.6.0~rc


libqgis-gui3.6.0,libqt5webkit5 5.6.0~rc


libqgis-gui3.4.4,libqt5webkit5 5.6.0~rc


libqgis-gui3.4.3,libqt5webkit5 5.6.0~rc


libqgis-core3.6.3,libqt5webkit5 5.6.0~rc


libqgis-core3.6.2,libqt5webkit5 5.6.0~rc


libqgis-core3.6.1,libqt5webkit5 5.6.0~rc


libqgis-core3.6.0,libqt5webkit5 5.6.0~rc


libqgis-core3.4.4,libqt5webkit5 5.6.0~rc


libqgis-core3.4.3,libqt5webkit5 5.6.0~rc


libqgis-app3.6.3,libqt5webkit5 5.6.0~rc


libqgis-app3.6.2,libqt5webkit5 5.6.0~rc


libqgis-app3.6.1,libqt5webkit5 5.6.0~rc


libqgis-app3.6.0,libqt5webkit5 5.6.0~rc


libqgis-app3.4.4,libqt5webkit5 5.6.0~rc


libqgis-app3.4.3,libqt5webkit5 5.6.0~rc


libprocessui7,libqt5webkit5 5.6.0~rc


libmyth,libqt5webkit5 5.6.0~rc


libqt5webkit5:i386,libqt5webkit5 5.212.0~alpha2-7ubuntu1


libqt5webkit5:i386,libqt5webkit5 5.212.0~alpha2-7ubuntu1


zeal,libqt5webkit5 5.6.0~rc


wkhtmltopdf,libqt5webkit5 5.6.0~rc


webissues,libqt5webkit5 5.6.0~rc


wallch,libqt5webkit5 5.6.0~rc


umbrello,libqt5webkit5 5.6.0~rc


ugene,libqt5webkit5 5.6.0~rc


supercollider-language,libqt5webkit5 5.6.0~rc


supercollider-ide,libqt5webkit5 5.6.0~rc


smtube,libqt5webkit5 5.6.0~rc


sleepyhead,libqt5webkit5 5.6.0~rc


skrooge,libqt5webkit5 5.6.0~rc


signon-ui-x11,libqt5webkit5 5.6.0~rc


sigil,libqt5webkit5 5.6.0~rc


seafile-gui,libqt5webkit5 5.6.0~rc


rocs,libqt5webkit5 5.6.0~rc


rkward,libqt5webkit5 5.6.0~rc


recoll,libqt5webkit5 5.6.0~rc


qviaggiatreno,libqt5webkit5 5.6.0~rc


quiterss,libqt5webkit5 5.6.0~rc


quassel-client,libqt5webkit5 5.6.0~rc


quassel,libqt5webkit5 5.6.0~rc


qtwebkit5-examples,libqt5webkit5 5.6.0~rc


qttools5-dev-tools,libqt5webkit5 5.6.0~rc


qt5-assistant,libqt5webkit5 5.6.0~rc


qml-module-qtwebkit,libqt5webkit5 5.0.2


qmapshack,libqt5webkit5 5.6.0~rc


qlandkartegt,libqt5webkit5 5.6.0~rc


python3-pyqt5.qtwebkit-dbg,libqt5webkit5 5.6.0~rc


python3-pyqt5.qtwebkit,libqt5webkit5 5.6.0~rc


python-pyqt5.qtwebkit-dbg,libqt5webkit5 5.6.0~rc


python-pyqt5.qtwebkit,libqt5webkit5 5.6.0~rc


psi-plus-webkit,libqt5webkit5 5.6.0~rc


psi-plus-plugins,libqt5webkit5 5.6.0~rc


previsat,libqt5webkit5 5.0.2


postbooks,libqt5webkit5 5.6.0~rc


phantomjs,libqt5webkit5 5.2.0


owncloud-client,libqt5webkit5 5.6.0~rc


nmapsi4,libqt5webkit5 5.6.0~rc


nixnote2,libqt5webkit5 5.6.0~rc


musescore,libqt5webkit5 5.6.0~rc


minizinc-ide,libqt5webkit5 5.6.0~rc


merkaartor,libqt5webkit5 5.6.0~rc


mediaconch-gui,libqt5webkit5 5.6.0~rc


marble-plugins,libqt5webkit5 5.6.0~rc


luminance-hdr,libqt5webkit5 5.6.0~rc


libvtk7.1-qt,libqt5webkit5 5.6.0~rc


libvtk6.3-qt,libqt5webkit5 5.6.0~rc


arc-gui-clients,libqt5webkit5 5.6.0~rc


libqt5qevercloud3,libqt5webkit5 5.6.0~rc


libprocessui7,libqt5webkit5 5.6.0~rc


libmarblewidget-qt5-28,libqt5webkit5 5.6.0~rc


libkreport3-plugin-web,libqt5webkit5 5.6.0~rc


libkf5webkit5,libqt5webkit5 5.6.0~rc


libkf5kgeomap10.0.0,libqt5webkit5 5.6.0~rc


libkadu,libqt5webkit5 5.6.0~rc


kvirc-modules,libqt5webkit5 5.6.0~rc


kvirc,libqt5webkit5 5.6.0~rc


ktorrent,libqt5webkit5 5.6.0~rc


kmymoney,libqt5webkit5 5.6.0~rc


kexi-web-form-widget,libqt5webkit5 5.6.0~rc


kdevelop52-libs,libqt5webkit5 5.6.0~rc


kdenlive,libqt5webkit5 5.6.0~rc


kadu,libqt5webkit5 5.6.0~rc


goldendict,libqt5webkit5 5.6.0~rc


goldencheetah,libqt5webkit5 5.6.0~rc


gammaray,libqt5webkit5 5.6.0~rc


digikam-private-libs,libqt5webkit5 5.6.0~rc


cutycapt,libqt5webkit5 5.6.0~rc


choqok,libqt5webkit5 5.6.0~rc


cb2bib,libqt5webkit5 5.6.0~rc


calligrastage,libqt5webkit5 5.6.0~rc


calamares,libqt5webkit5 5.6.0~rc


brewtarget,libqt5webkit5 5.6.0~rc


arora,libqt5webkit5


Dependencies:


5.212.0~alpha2-7ubuntu1 - dpkg (2 1.15.6~) libc6 (2 2.27) libgcc1 (2 1:4.0) libglib2.0-0 (2 2.37.3) libgstreamer-plugins-base1.0-0 (2 1.2.0) libgstreamer1.0-0 (2 1.4.0) libhyphen0 (2 2.7.1) libicu60 (2 60.1-1~) libjpeg8 (2 8c) libpng16-16 (2 1.6.2-1) libqt5core5a (2 5.9.0~beta) libqt5gui5 (2 5.9.0~beta) libqt5network5 (2 5.9.0~beta) libqt5positioning5 (2 5.6.0) libqt5printsupport5 (2 5.0.2) libqt5qml5 (2 5.1.0) libqt5quick5 (2 5.9.0~beta) libqt5sensors5 (2 5.6.0) libqt5webchannel5 (2 5.6.1) libqt5widgets5 (2 5.4.0) libsqlite3-0 (2 3.7.15) libstdc++6 (2 6) libwebp6 (2 0.5.1) libwoff1 (2 1.0.0) libxml2 (2 2.7.4) libxslt1.1 (2 1.1.25) qtbase-abi-5-9-5 (0 (null)) qtdeclarative-abi-5-9-5 (0 (null)) zlib1g (2 1:1.2.0) libqt5webkit5:i386 (35 5.212.0~alpha2-7ubuntu1) libqt5webkit5:i386 (38 5.212.0~alpha2-7ubuntu1)


Provides:


5.212.0~alpha2-7ubuntu1 -


Reverse Provides:

Con lo anterior se puede comprobar que si desinstalamos este paquete, muchas aplicaciones van de dejar de funcionar. Por ese motivo siempre es conveniente que si un paquetes se encuentra sin soporte, se compruebe si se puede reemplazar por otro o simplemente de desinstala si no es necesario.

(Visited 38 times, 1 visits today)

Comments

comments


Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *